Discussion in 'Bugs' started by Skyblade799, Jul 13, 2011.

  1. scotth

    scotth Member

    Unfortunately, I haven't been able to get past the setup screen. Regardless of resolution or windowed/full screen choices I make, I simply get black. No sound.

    Edit: tried again and walked away. Came back some time later and game was running properly. Apparently just takes a long time to load - at least for me.
  2. Amigan

    Amigan Member

    I've just encountered the corrupted save bug that others have mentioned.
  3. zukeft

    zukeft Member

    I haven't played or done much testing really, here's a couple of bugs (Windows 7 64-bit):

    1. Using your mouse wheel (scrolling) and middle mouse button does the same as left clicking on the main menu items.
    2. Tutorial stars stay onscreen when going down the list. (Compare the two screens: http://imgur.com/5i1Mm)
    3. Tutorial completion state is not saved. (?)
    4. A window icon is missing. (?)
    5. Clicking the window close button does not exit the game. (?)
  4. lithicbee

    lithicbee Member

    I finally survived to 3rd level and now it appears that my save is corrupted. I can send you the file, but where can I find the file on a Mac? Thanks.
  5. Nicholas

    Nicholas Technology Director Staff Member

    lithicbee: ~/Library/Application Support/Dungeons of Dredmor I believe ?
  6. gkslash

    gkslash Member

    I really have to say that the randomly crashing is just about making the game unplayable for me. I really like the game too. Its hard enough on going rogue and permadeath without having to worry about when the game is going to randomly crash as well.
  7. lithicbee

    lithicbee Member

    Started a fresh character. Did a save and continue and it kicked me to the title screen. tried to load the save and it crashed the game.
  8. lithicbee

    lithicbee Member

    @Nicholas: thank you. I was looking for it under the steam subdirectory.
  9. shung

    shung Member

    I keep stepping on traps right before I go to open a door on the south and west side of the map. All things that are being hidden by a wall or door should have some kind of outline that you can see.
  10. Skyblade799

    Skyblade799 Member

    When I sell things to a merchant, upon clicking an option, the game will assume I also clicked him and try to attack him. I have died twice because of the merchant getting attacked and hit while selling things ):.
  11. Halaku

    Halaku Member

    Putting in my voice as well on the random crashes bug, really enjoying the game until that happened. Would love it if you guys could fix it so we can play the great game we bought.

    One not-bug but bugs me note, exploring to the sides or above you gives a decided 2-3 tile visual benefit as compared to exploring downward, any plans to correct this or is going down always going to be more dangerous simply due to "camera issues"?
  12. xfer777

    xfer777 Member

    Is it just me or do the bonus points for the Dual Wield skills not get added to your stats?

    For example, I have all 3 of the Dual Wield skills - by them alone I should have a total of +10 to counter chance, shouldn't I? On my character, I only have a chance of 3 (without any other +counter items).
  13. jbuergel

    jbuergel Member

    I've had a couple of crashes going through the tutorials on my Win 7/x64 machine. It produced a couple dump files, if those are helpful. I'm going to try the game proper now, hopefully it's isolated to the tutorials.
  14. skeena

    skeena Member

    I discovered what I think could be a pretty big exploit.

    I started a new game to try out some spells, and when I died and I selected my OTHER character I had the same spell still selected in the ready box even though my character did not invest in that branch. And I could use the spell until I changed it out.
  15. Gamidragon

    Gamidragon Member

    So just started a new game (I don't want to wait, this stuff is WAY too fun!) and played for another hour or so, and saved, and then went to reload immediately and it worked! I loaded it twice more just to make sure and then quit out. I'll update/edit this post (can I edit?) later tonight or tomorrow morning as to whether I can still load the file. At least it doesn't ALWAYS happen!
  16. Zzinged

    Zzinged Member

    Here's a bug I just noticed. The footsteps SFX only plays if you click to move. If you move using WASD it doesn't play the footsteps SFX
  17. d32

    d32 Member

    - Picking up item (sword) while 'holding' another (mace) resulted in disappearance of the held item in tutorial.
    - Killing prinny, I mean diggle, by the crossbow did not trigger any events (tutorial section end?)
    - Pressing enter to dispose of dialog message results in following messages being disposed as well.
  18. MorphingJar

    MorphingJar Member

    When starting with the Crude stone axe, if you switch it from the primary hand to the secondary hand, it mystically adds 1 point of slashing damage to your ranged attacks.
  19. Valygar

    Valygar Member

    I am trying to load a save, but it does not exist. I am pretty sure I quit the game saving, and I saved once already with this character. Don't know if it's the crash save, probably?.

    In my documents there's a loadsave.dat (1 KB) and bitmap_Duerko.dat (my char was named Duerkos)
  20. Chief

    Chief Member

    My save file got corrupted or something like other people have mentioned. Played for around 8 hours with no problems, loaded many times, then suddenly went to load after yet another death and the game crashed. Happens every time I try to load that save, but other save games load without issues.