Bugs and issues still present in 1.03

Discussion in 'Bugs' started by Pecka, Jul 19, 2011.

  1. lgoasklucyl

    lgoasklucyl Member

    I had my game crash and my save disappear going up a flight of stairs =/ Post update, on OSX 10.6.7 if it matters. Had followers (possibly) on the floor (the level 5 fungal guys).

    Probably won't play again until a bunch more patches. Losing a four hour save is super painful, don't want to take that chance again.

    Good luck working the bugs out, gentlemen. Use the money I spent on an unfinished game to get those devs coding xP

    See you in a couple months!!!
  2. Bakyra

    Bakyra Member

    I really love how a *bug* thread turned into a suggestion thread.

    Anyway here's my contribution:
    If you're trying to disable an arrow trap (nasty acid arrows) and you cover yourself behind a wall, being on the EAST side of the trap will still get you hit, while hiding on the WEST side of the trap will make the projectile hit the wall. All the time, at all positions.
  3. jareddm

    jareddm Member

    @Igoasklucyl the mac patch isn't out yet.
  4. Patchumz

    Patchumz Member

    @lgoasklucyl As stated, the Mac patch for 1.0.3 isn't out yet. But while you wait why not download Lion from the app store ;). That'll take your mind off things.
  5. GammaPaladin

    GammaPaladin Member

    Personally I'd like it if the game would save my window positions between games. I like having my inventory window in a certain spot, my map open to it's largest setting, the lutefisk cube window in a certain spot, etc. and I have to set this up every time I start a new game, or even load an old one. It's frustrating!

    Also, the character window, where your stats and gear are shown, can't be moved, and probably should be moveable.
  6. mwoody

    mwoody Member

    My big wish for a fix is the attribute balance. As it stands, when you level up you get six attribute points if you pick a warrior skill, eight for rogue, and twelve for mage. And yes, this applies to the seven points worth of stats you get at the start. So a pure warrior starts with HALF the stats - including melee stats - as a pure mage.

    This is made particularly bad because Caddishness buffs HP, despite not saying so in any tooltip text. So a mage can expect to more than double the max HP of a comparable warrior.
  7. Currently, I;m having an issue with saving games and wanted to know if anyone has had the same.

    Save & Continue: Will not save at all.

    Save & Quit: Will save progress anywhere 10 minutes to half an hour back, but will not save current position.

    There is also an "Autosave" now, which mirrors my "Save & Quit".

    My previous 1.0.3 save has now vanished.

    Anyone else?
  8. Nicholas

    Nicholas Technology Director Staff Member

    @Patch We haven't tested compatibility with Lion yet, but we have heard there may be issues.

    It never rains but it pours for you guys, does it?
  9. lBReTTl

    lBReTTl Member

    Seems that when i open doors and monsters are there i just get attacked and cannont attack anything, as soon as i move away i can attack again. Im not sure if its a bug or something else though.
  10. EttBjurn

    EttBjurn Member

    Having a issue with saved games aswell, when i try too save & quit on permadeath mode the game crashes all the time.
    Dunno what causes that, but i try to redownload the game and try again.
  11. EvilCanadian

    EvilCanadian Member

    So I apologize if these bugs have been reported already but:

    WASD to open doors and attack: If used to open a door (haven't tried with attacking yet but I assume it is similar) it will cause your mouse cursor to disappear.

    Permadeath saves not deleting on load: Not technically a bug I suppose because it is working as intended, but it allows the following exploit:

    Come 1 hit from dying
    Quit without saving
    Load previous save
  12. mrsachmo

    mrsachmo Member

    I had my game crash after 4 hours. I wasn't doing anything special, but i had previously gone up and down the stairs a number of times. I was level 4, i believe, with 3 weapons specs, rage, and a few other things. I was doing a lot of back and forth and had deleted a couple of quests as well. However, at the time, I was just walking up a hall.

    I have also seen the Save and Quit not actually work before. However, I can't reproduce.
  13. StriderX

    StriderX Member

    So far, the only glitch I've encountered was a monolith and a BBQ that had spawned on the same tile. I could only interact with the monolith.
  14. Ria Hawk

    Ria Hawk Member

    I had a problem where after loading a save from yesterday, I couldn't add anything to a stack of Aqua Vitae. I could start a new stack, and I could use the old stack just fine, but that was it. It wasn't a cap issue, because I tried adding a new bottle to the stack after using an existing bottle, and it didn't work. But Aqua Vitae was the only thing that happened with that I could see.
  15. benetar

    benetar Member

    I tested save games after hotfix-- Still crashing. Is the hotfix actually out on steam yet?
  16. UltimateCarl

    UltimateCarl Member

    A few things here:

    - My pet appears to be able to occupy the same spot as monsters sometimes. I'm not sure how this happens, and it's pretty rare, but it seems odd, especially since my pet cannot attack the creature (I can, thankfully I target the monster rather than my pet) and the creature will target me since it can't "reach" my pet.

    - Tiles that are originally occupied by a wall and changed to a floor (secret passages opened with switches, walls blown up with Bolts of Mass Destruction, etc.) cannot be moved into or through by clicking, as if the game thinks it is still a wall. I can still move into these tiles by using WASD, however. It's not a huge problem, but a bit annoying since I use the mouse almost exclusively, but I have to use the keys to pick up items in secret passages.
  17. Herborist

    Herborist Member

    I don't know if this has been said already, but if you open a door and then start fighting something without moving, the game won't take your attacks into account. It's like passing the turn - you'll just kept being attacked over and over.

    I've almost died way too many times to this bug.
  18. NefariousKoel

    NefariousKoel Member

    The crafting tooltips are there (for what you're going to make), they just show up behind the crafting window so we don't see it but for a small part sticking out from the bottom item when moused over.
  19. Maxion

    Maxion Member

    Playing with permadeath on, got blown up by a fire rune right as i went up some stairs, came out dead on the floor above, congratulations, you have died, then the game crashed, no save to be found anymore, and no highscore recorded from the 12 hours i spent on that save. >_<
    (not playing on a mac, so I do indeed have the 1.0.3 patch installed)
    Also, mastering the archaeology skill gave the smithing achievement, though it has since changed back into the archaeology achievement.
    Edit: Apparently my score got listed on the steam leaderboards, but not the in game local highscores.
    Though something needs to be done to prevent people cheating to get high scores, don't know how they do it, but some scores are so ridiculously much higher than the rest that they must have been cheating, unless they somehow manage to block themselves in and set a macro to spam spacebar and wait for random mobs to get killed by gargoyle traps, I dunno.
  20. Oooops. Was trying to update my pet post and accidentally repost the whole thing in a new reply.
    please delete this post.