Bug reports

Discussion in 'Conquest of the Wizardlands' started by ploki122, Aug 1, 2012.

  1. ploki122

    ploki122 Member

    Apparently, while trying to beat Diggle Hell at low level, I managed to corrupt my game...

    When I finally managed to clear it and get back to my "home". I tried to go back to the regular dungeon and the whole application closed (no error message) - N.B. There was still a portal open when I came back... I tried to load, re-clear the last room, close the portal (empty code) and it did the same result.

    Take #3, I used the pocket button to warp back and it simply warped me to the middle of the current map (Diggle Hell). I ran back to the end-portal (since the button would now warp me to my current square). While going back I saw that I had 2 hero icons on the mini-map. Also, I had lost all the gear acquired in Diggle Hell... I thought it wasn't so bad since I kept the levels (still not sure to this day), but when the 2nd hero would have shown up, the game crashed (with error message this time).

    I'll toy around with this a little more to see if I can get a workaround...

    P.s. added my savegame in case you want to see the bug for yourself...

    EDIT: Apparently, the hero I control after "teleporting back" is an exact copy (items, levels, equipments, etc.) of the one that entered diggle hell... Also, the game crashes (with message) even if I don't cross my doppleganger

    Attached Files:

  2. Haldurson

    Haldurson Member

    I think that the Bankster skill achievement is broken.
  3. ploki122

    ploki122 Member

    Oh... yeah... talking about achievements, I didn't get the one for praying the diggle devil.

    EDIT : or for dying to probably every kind of diggle once...
  4. Bohandas

    Bohandas Member

    I've experienced two major errors (or three, depending on how you parse them):

    1.) Pressing the button to enter the pocket dimension sometimes crashes the game

    1b.) Returning from the pocket dimension can cause problems as well. At one point it returned me to the level inside of a solid wall. Reentering the pocket dimension and going back to the level again did not help and as I had no digging or teleporting abilities I was stuck (I was able to get unstuck by loading the game in debug mode, going down one level, and then taking the stairs back up to the original level (the debug command to go up a level didn't work from where I was stuck, and going up through debug from the same impassible wall)). It should be clarified that I was not in one of the hidden empty spaces; I was actually in the wall; The character was not visible on the screen and I was only able to determine her position by casting a spell and noting the location of the spell animation.

    2.) The third level ability of the Paranormal Investigator skill tree crashes the game about half of the time when it is used
  5. Nicholas

    Nicholas Technology Director Staff Member

    In fact, you shouldn't have access to the pocket dimension while *in* a wizard level, so I'm not sure why it's showing up in Diggle Hell in the first place. We'll take a look.
  6. ploki122

    ploki122 Member

    lol... might be related to how I don't seem to be "in" the diggle hell level...
  7. rory

    rory Member

    Yep, that happened to me too.
  8. ploki122

    ploki122 Member

    Apparently, launching 1 of the tutorial crash DoD too... oh well, time to go to sleep...
  9. Countmore

    Countmore Member

    Dagger skill achievement was bugged for me as well.
    Also, crashed on completing the first tutorial.

    Edit: Rather, crashes on continue to next tutorial.
  10. Nick Coelius

    Nick Coelius Member

    Communism 1st skill invisibility functions as invisibility used to - the monsters follow you every step of the way.

    XP appears to be defaulting at 0 every level, again, with no roll-over. First noticed when I killed Bee Arther for +240 XP, had 272/250 when I selected my skill, and then went down to 0/250.
  11. Gresh'Kaal

    Gresh'Kaal Member

    Maybe my adventurer was in utter denial about missing, but a sleeping raven dodged my attack twice in a row... Without waking up.
  12. FamilyDollar

    FamilyDollar Member

    Not sure if this is intended and I just never noticed it about the other weapon skills, but all of the daggers skills appear to work even when daggers are not equipped. This includes procs, passives, and activated skills. Sorta cool to be getting crazy dagger procs while using a polearm and sword, but doesn't quite seem right...
  13. Wolg

    Wolg Member

    Has anybody else seen Public Option (from Communist) fail to provide healing when activated? (Or is there a condition for this that I'm not aware of?)
  14. SamuelMarston

    SamuelMarston Member

    I just crafted my two Clockwork Drill Lances, and I realized that I was swinging them like a baseball bat. Oops! Clockwork Drill Lances are still listed as Staves.

    EDIT: This is a super simple fix for anyone who has done any item modding. It's as easy as looking up the Clockwork Drill Lance in the itemDB file for Expansion 2. Change the weapon type from "3" to "8."

    As far as I can tell, this won't even hurt your current saves. Mine wasn't affected at all.
  15. Shivs stack. This can result in an artifact shiv becoming a regular one. I just had a quest reward immediately become an ordinary shiv by stacking onto one in my inventory! Boo!

    Added: I'm not wholly certain if it's a bug or no, but I swear I've hit the lobster-mace room twice-per-level-1 pretty consistently over the last 4-5 characters.
  16. darius404

    darius404 Member

  17. Haldurson

    Haldurson Member

    Paranormal Investigator achievement is bugged also 8-(.
  18. John Lee

    John Lee Member

    I found a really neat-looking Wizardlands level, but it didn't appear on my list of options for the Pocket Dimension backgrounds. A very minor, low-level bug, but I had been looking forward to it.
  19. Haldurson

    Haldurson Member

    It's my understanding that the elements that you can choose are tied to the deepest level of the REGULAR dungeon that you've explored, not the appearance of the wizardlands you've explored. At least that's how its been working for me.
  20. John Lee

    John Lee Member

    Ah, I had thought I heard from some official source that you could. (Great info sourcing there, eh?)
    Well, either my mistake, or teeny bug. Either way, I'd like it to be an option!