Discussion in 'Clockwork Empires General' started by Nicholas, Jun 27, 2016.

Thread Status:
Not open for further replies.
  1. Nicholas

    Nicholas Technology Director Staff Member

    Please note: commodities wouldn't be fixed if you are loading a 0.52 save game. You need to start a fresh game in 0.52A to have any chance of an accurate commodity count; by the time you save with broken commodities in 0.52, they're already toast.
  2. Unforked

    Unforked Member

    Playing a fresh 52A game now. I'm about ready to save a game in which a module "eats" commodities when a colonist tries to build something with multiple inputs and gets interrupted by a shift ending, thus starting over. Not sure this has anything to do with commodity counts (that seems ok), but this has been going on for a few builds.
  3. Nicholas

    Nicholas Technology Director Staff Member

    Different bug, but I can certainly look into it. People's jobs should not be interrupted by shifts ending, for what it's worth; they should finish their current task. So if that's happening, that's definitely a bug.
  4. Bluebird

    Bluebird Member

    Attached Files:

  5. Bluebird

    Bluebird Member

    They are definitely not dropping them - the goods seem to disappear though traders thing they still have them.
  6. Unforked

    Unforked Member

    Yeah, this time I couldn't catch it. The colonist building a leyden pistol locker worked through tea time as you said they should.

    I swear it happened earlier in the game when I was making a brick charcoal kiln though, but I don't have a save for it. I watched him closely: He put in the two iron ingots, took a break, then started over putting in two MORE iron ingots. I know this is happening... but maybe it has nothing to do with breaks.
  7. dbaumgart

    dbaumgart Art Director Staff Member

    The interruption is due to something else, likely fleeing from a hostile, and a couple other rare cases maybe. (Workshift changes *never* interrupt the current job.)

    Interruption (unfortunately) destroys any materials consumed by the job up to that point, so it'll only affect production orders that require multiple types of ingredient. We've discussed a solution and logged it as OC-5077.
    Rentahamster and Unforked like this.
  8. dbaumgart

    dbaumgart Art Director Staff Member

    Found the trade problem. It's, ahem, important to distinguish between "trade_office" and "trade_depot", it turns out. Surely the Ministry has a nomenclature standards guide somewhere ...

    Anyway, fixed for 52B.
  9. Naffarin

    Naffarin Bureaucrat-Inspector Exemplar of The Empire

    You can log OC-5075 as a duplicate to OC-5077 then, because the issue there was that production of items with multiple types of ingredients and interuption of the overseer.
    dbaumgart likes this.
  10. Unforked

    Unforked Member

    Thank you! This has been a mysterious thorn for a while now. So glad the problem is identified and will be fixed!
  11. dbaumgart

    dbaumgart Art Director Staff Member

    Okay, need some more clarification (if you could): Are you saying that a bandit attacked your Ceramics Workshop and destroyed it? Or did they literally pull out a hammer and disassemble it? (Which would be the weirdest bug ever, but hey!)

    And it IS possible to set a bandit to hostile even if you've formerly made peace with the bandits if you plunder their tents and they notice. Is this what happened?

    If you could attach a save game showing this happening, I'd appreciate it. I'm having trouble understanding what is going wrong.
  12. Samut

    Samut Member

  13. Mikel

    Mikel Waiting On Paperwork From The Ministry. Forever.

    How can you have any pudding if you don't protect your meat?
    PartTimeVillain and Marak like this.
  14. gmkchicago

    gmkchicago Member

    Attached is the save game. Look for the overseer without any special skill.

    Attached Files:

  15. Alephred

    Alephred Royal Archivist for Queen And Empire

    The problem you describe has been an issue since whenever the military auto-promotion was added to the game (I hope the Devs are already aware of it, since it's been reported before). I've never seen it function properly.
  16. tojosan

    tojosan Member

    Favorite new feature: module placement shows greyed out modules.
    If you pickling I'd be happier. I keep making bottles but pickling seems only to work on fungus and not always.
  17. DaCrAzYmOfO

    DaCrAzYmOfO Member

    They were attacking me before I plundered the tents, the "your building is under attack" popup came out. From what I remember they attacked my buildings and when I went to check my ceramics workshop it was already in its different pieces.
    I took this screenshot to show someone the bandit tents were still up.

    I was unable to recreate this, but I did include the before and the after save, after my battle.

    Attached Files:

    Last edited: Jun 28, 2016
  18. DaCrAzYmOfO

    DaCrAzYmOfO Member

    Also, this is from the same game after I tried recreating that bandit trouble. There seems to be a stack of monoliths and gold in the corner of the map, I remember this happening a few versions back but I thought it was fixed. I believe this is before the hotfix so ya'll might have already got to it.

    Attached Files:

  19. DaCrAzYmOfO

    DaCrAzYmOfO Member

    Here's something else that I found, maybe a bug, maybe not.

    You don't need to conduct mineralogical surveys to harvest minerals from nodes.

    Attached Files:

  20. Blyn

    Blyn Member

    i don't know about dismantling buildings, but i did make peace with the bandits and they just walked into town and took my good stuff!
    as soon as they put it down a colonist walked over to their camp and took it back to use it!
    the bandits let him take it because PEACE!

    how annoying!
    the events said they would be ruffians prone to the drink etc but i had no way to stop them!

    i suggest peaceful bandits be made similar to fishpeople, free to wander town, eat, drink, and mess up the pub, gifting unwholesome items here and there.

    also strong words and beatings!
Thread Status:
Not open for further replies.