Discussion in 'Clockwork Empires General' started by Nicholas, Jun 27, 2016.

Thread Status:
Not open for further replies.
  1. Nicholas

    Nicholas Technology Director Staff Member

    Beta 52A is on the experimental build! We think we have finally, FINALLY sorted the commodity issues. Please let us know if this ain't the case.

    Major Changes:

    added building mode description widget (so if you're placing blueprints, it says so, and provides a "Done" and "Cancel" button.)
    modules and buildings will return their materials when dismantled! Get Hype!
    commodity count should be totally fixed and correct! (If it looks funny to you, please let us know.)
    fixed certain display issues for people on terrifyingly large monitors

    Full Changelog for beta 52A:

    animals now eat forest meat
    removed trader item drop on flee
    added additional error checking in "vicar_take_confession" fsm
    Bandits will become enraged (and an alert will appear) if you forage their tents when they're nearby
    modules will return their materials when deconstructed
    modules slated for dismantling will display an icon to show that they have been so designated
    buildings will return their construction materials when dismantled
    changed "Bricabrac" to "Bric-a-brac" upon order of the Dept. of Pedantry
    made people smarter about keeping guns loaded
    Steam Knights now contribute significantly to colonists' feeling of safety
    text numbers for commodities in module placement tooltips turn red if that material requirement can't be fulfilled
    module placement button grays out when material requirements can't be fulfilled
    added sounds to a number of steam knight animations
    added "?" box tutorial for farms
    added unique model for moonshine
    standard welcome event should overflow the text box less often
    made module menu glass buttons a bit more opaque
    balance: added clay at all to Boreal Forest
    FIXED: fixed up "slapped_other" type memory names
    FIXED: "You recieved 1 immigrants" grammar issues
    FIXED: <building_destroy_item/> did not actually delete commodities in a stack (this affects Make Stone Bricabrac etc.)
    FIXED: a couple of crashes switching in and out of building creation modes
    FIXED: Cancel button works for building creator
    FIXED: highlighted region now corresponds to where your mouse is in full screen mode when game is run with a backbuffer that is larger than the display area
    FIXED: smelt gold ingots
    FIXED: label on bottle laudanum job
    FIXED: icon on brick charcoal kiln
    FIXED: brick charcoal kiln construction requirement
    FIXED: explore waypoints can now be properly cancelled
    FIXED: "Repair Module" job now restriction to workcrews with "construction" enabled
    FIXED: sermon-giving issues
  2. LeChatMG

    LeChatMG Member

    Am I right if I assume that the "Upkeep: 1 <Bushel of Sausages icon>" on the Carpentry Workbench module list tooltip is a leftover from some kind of internal feature testing? :p
  3. Nicholas

    Nicholas Technology Director Staff Member

    ... ah. Yes. Please do not put sausages into the carpentry workbench module.
  4. Alephred

    Alephred Royal Archivist for Queen And Empire

    It seems to me the Power Saw would be the perfect place to slice your Deathwurm Bratwurst. Wurmwurst, as it were, the revolting native dish of the Antipodean jungle.
    Unforked likes this.
  5. advkow

    advkow Member

    Or is it perhaps the most hidden secret of the game?
  6. gmkchicago

    gmkchicago Member

    Still having issues with crafting goods with multiple inputs. Took several attempts to create the iron oven (plates, pipes, and bricks), and the commodities were lost if the builder was interrupted.
  7. Unforked

    Unforked Member

    Yeah, this is the big one. Tea time or night hits and colonists tend to forget they had already started making something, so they start completely over when a new shift begins. But the initial commodities from their original incomplete attempt had already been eaten by the smelter or workbench etc.

    I'll try to get another save that demonstrates this.
    Last edited: Jun 28, 2016
  8. DaCrAzYmOfO

    DaCrAzYmOfO Member

    So... if you're peaceful with the bandits... and they wander near camp... they disassemble your buildings? I just had a bandit come up to my town and disassemble a ceramics workshop!!!!
  9. DaCrAzYmOfO

    DaCrAzYmOfO Member

    and FYI make pickled chilies doesn't work. I have the items in my inventory and my overseer is just idle on shift or he sits there cleaning the workshop. I've wanted to make these for a long time :( I wish they would get fixed.


    I loaded up that save after posting this and it took me to before I had the workbench up. Either way this has been an issue for quite a few versions now.

    Attached Files:

  10. Unforked

    Unforked Member

    Woah, that's a pretty crazy bug! I haven't made friends with bandits in ages (they're pretty harmless lately), but I might have to try it just to see that! :D
  11. Naffarin

    Naffarin Bureaucrat-Inspector Exemplar of The Empire

    Commodity issue still occurs for me in the old save from 0.52. In the save game attached place an order for 3 small iron ovens in the metalworks. the 3 iron plates and pipes are available in the stockpile at the door, the bricks are located in another stockpile.
    The bug seems to be occuring when the overseer is doing the crafting, if one of the group members is doing it, everything seems to be running fine.
    Will test a new game start afterwards.

    Attached Files:

  12. Bluebird

    Bluebird Member

    Still have phantom traders arriving with no goods in their hands. The hands are outstretched but nothing in them

    Also, got loads of glass plates but they are not appearing in the list for trading despite being selected.

    And one last weird one : made 2 pipes and plates ready for iron smelting furnace. One moment they were there then gone - nothing used them just poof ....

    Attached Files:

  13. Tikigod

    Tikigod Member

    Anyone that has tried the build able to say if the bug where workshops don't clear out old production modules from the activity list when they're demolished is resolved in this experimental?

    As I tend to do a lot of tweaking and replacement of old modules, the fact the workshop window is incapable of updating itself to not list modules that have been removed from the workshop eventually makes trying to order things more hassle than it's worth trying to remember if unspecified workbench 1,2,3 and 4 in the list were the new ones or the old ones that don't exist anyone yet can still be assigned production orders to them which achieves nothing.

    Or progressing from stone to brick modules, removing all the stone ones as I go and yet still having them flooding up the workshop window list is equally annoying and something that has been lingering around as a annoying oversight for some time now.
  14. Rentahamster

    Rentahamster Member

    @Tiki, I usually just build the workshop large enough at first to accomodate all the new modules as well as the old/obsolete ones. Or, you can prebuild all the new modules, then quickly demolish and remake a new workshop. As long as you have a workcrew with a few workers on it, it shouldn't take more than half a day to complete and be back up and running.

    Forbid the stack, then reclaim it, then mark it for trade again.
  15. Bluebird

    Bluebird Member

    OMG .. it even worked :) Thanks. No idea why I did not think of that but excellent !
    Rentahamster likes this.
  16. Rentahamster

    Rentahamster Member

    You should actually refine those glass panels into bottles and trade the bottles instead. You get more value.
  17. Bluebird

    Bluebird Member

    Example save with traders just arriving and dumping goods away from trading post.

    Attached Files:

  18. dbaumgart

    dbaumgart Art Director Staff Member

    Uh oh. Logged as OC-5073, should be straightforward.

    Logged as OC-5074. Should also be straightforward, thank you for the save game.

    Thanks for the save and repro steps, will check this out. Logged as OC-5075.

    Awesome, love getting saves. Logged as OC-5076, will see what's going on in there.

    (Really weirded out that traders would have no goods because I literally removed the command where they'd drop them! Unless there's another one hiding somewhere ... )

    Yes, this should be fixed by Nicholas yesterday for the patch. AND it updates immediately in the workshop window when you give the dismantling order.

    Excellent, thanks for the save. Will check it out along with the other one on OC-5076.
  19. dbaumgart

    dbaumgart Art Director Staff Member

    Found and fixed the issue with pickling chillies for 52B! (They were searching for the wrong object tag on chillies, it turns out.)
  20. gmkchicago

    gmkchicago Member

    I'll attach a save game later when my internet speed improves. I had a bug with NCO promotion. The NCO/overseer was killed and another member of the crew was promoted. However, the new leader is not acting as a leader, the crew is not in military gear either. I finally switched overseers, and the newly promoted overseer does not act like an overseer when assigned to a workshop (he just idles or wonders near overseer).
Thread Status:
Not open for further replies.