Discussion in 'Clockwork Empires General' started by Nicholas, Jun 21, 2016.

Thread Status:
Not open for further replies.
  1. Nicholas

    Nicholas Technology Director Staff Member

    Full changelog:

    Changes since REV 51J (yeesh!):

    FIXED: Sulphur Tonic job said it makes Fertilizer when it really makes Tonic
    FIXED: doing science now increments Science skill
    FIXED: Jezail Rifle lockers scavenged from bandits can now be placed
    FIXED 51J: chilli stew production amount corrected
    FIXED 51J: workshops would display unformatted skill info
    FIXED 51J: scripterror in Steam Knight favour
    FIXED: The posessive and objective forms of gender-neutral pronouns were reversed.
    FIXED: when merging containers, ensure that the dead container is correctly removed from the container manager (may have caused issues)
    FIXED: always set containers to visible when something is put into them in a stockpile (workaround for a mystery bug)
    FIXED: ESC when entering module mode and then not selecting anything would incorrectly hide all tooltips.
    FIXED: brick charcoal kiln
  2. DaCrAzYmOfO

    DaCrAzYmOfO Member

    Hi I haven't tried B52 yet but the pickled chilies aren't producing on 51J. :S
  3. It's been a couple months since I played some CE, but I'm tempted to give this new build a try and see how much things have progressed. It'll be nice to see how the steam knight works now compared to when it was included in earliest access.
  4. Nicholas

    Nicholas Technology Director Staff Member

    My main hope is that we have, FINALLY, put the commodity issues to bed. That's deifnitely the #1 issue in terms of people's workshops freezing up and jobs locking up, and so therefore I really want to ensure that we have accurate commodity counts and everything working happily.
  5. Mad_Ludvig

    Mad_Ludvig Member

    Is 52 supposed to be pushed to the experimental branch too? I had to switch back to main to get it.
  6. Nicholas

    Nicholas Technology Director Staff Member

    It should be on both.
  7. tojosan

    tojosan Member

    Save and exit to main menu drops completely out.
  8. DaCrAzYmOfO

    DaCrAzYmOfO Member

    Started on 52 now, pickled chillies still not producing.
  9. mikail 001

    mikail 001 Member

    is it possible to queue production orders at any module? if yes, what is the key command to do it?
  10. Sethiusdraven

    Sethiusdraven Member

    not yet
  11. Manamoo

    Manamoo Member

    It is crazy that just last week we were on 51E and here we are 52...Cheers to @Nicholas and the rest of the Dev's! Working weekends, with the plague, no sleep...just to get the game fixed for us to play....and sniff out the bugs.

    On a side note maybe a glitch but if it is it will be on the very bottom...if you exit to main menu without save too many times it will crash. I think it is about 5 or 6 times. I am picky and while I'm not sure if the Traits are working or not...I did not want a Lazy, Laudanum, Craven Farmer as an The combo's are fricking hilarious sometimes. That's the only issue I have seen thus far...
    tojosan, Unforked and Tarod like this.
  12. Sethiusdraven

    Sethiusdraven Member

    looking good so far: very nice job
  13. Akuma

    Akuma Member

    It's playing alot better since I last checked in before the beta.

    Only things I've come across at the moment are:
    • Big Buildings, Beyond 7x7, are ignored. No one builds them.
    • 'Strange Objects' don't get picked up unless I forbid them and then claim them
    • When I built my first wheat field, I assigned it but then it assigned one workcrew to both the new wheat field and the old maize field
    Last edited: Jun 22, 2016
  14. wargarurumon

    wargarurumon Member

    odd, seems that trade isn't working. i'm sending my products but not getting anything in return
  15. Unforked

    Unforked Member

    Do you have all the building materials? If you need say, 15 planks, they won't even start building until someone can gather all those planks at once, whereas in recent builds (pre- beta) they'd place them one at a time.
  16. Wolg

    Wolg Member

    Say Nicholas, is it expected that CE tries to open network connections on startup?
  17. DaCrAzYmOfO

    DaCrAzYmOfO Member

    Crash when I gave in to bandit's demands. They were about to get to the colony to take the goods.

    Attached Files:

  18. Nicholas

    Nicholas Technology Director Staff Member

    Yes, although it's actually through the Steam API.
  19. Alianin

    Alianin Member

    When trying to cancel out of the building design screen, the Cancel button does not work. I have to hit Esc for it to close out.
  20. Nicholas

    Nicholas Technology Director Staff Member

    Fixed, but this entire interface block is going bye-bye in the next couple of experimentals anyway. :)
    Alianin likes this.
Thread Status:
Not open for further replies.