BETA 51A BETA 51A Hotfix Now Live!

Discussion in 'Clockwork Empires General' started by Daniel, May 22, 2016.

Thread Status:
Not open for further replies.
  1. Daniel

    Daniel CEO Staff Member

    BETA 51A (A hotfix for Beta 51) is now live on the main branch, with fixes for a few issues that people found that were causing instability.


    FIXED: Make Copper Plates job
    FIXED: Make Wooden Altar job
    FIXED: memories and emotions hanging midair, predominantly for people with multi-monitor setups
    FIXED: hitting esc to back out of a module recipe selection screen would leave the UI in a state of purgatory where literally anything you did next would crash the game.
    FIXED: clicking on the trade depot crashes the game
    FIXED (hopefully): phantom items occasionally left on the ground during stacking, building workshop transformation operations
    FIXED: q and e are now bound hotkeys for camera moving left and right, rather than hardcoded
    FIXED: Make chemistry workbench job
    added "-opengldebug" command flag to return additional OpenGL debug information; please use this and send us the results if you are experiencing crashes on startup!

    You may notice that this is exactly the same changelog as the Hotfix 51A changelog. Well, that's because it's the same version :) We have found a TON of other stuff that we want to improve for the subsequent experimental versions, but since the default branch is primarily about stability, further UI improvements and other updates will be going to the experimental branch until we roll out another build to default.

    If you are on a crashing AMD or OS X machine, please pass "-opengldebug" to the game as a starting parameter (you can do this on Steam) and send us the console file!
    Unforked likes this.
  2. Unforked

    Unforked Member

    Now go sleep guys.:)
  3. Cyjack

    Cyjack Member

    Still getting that weird thing where the Welcome screen and tutorial spontaneously pops up in the middle of the game.
  4. Bluebird

    Bluebird Member

    Guess this needs a new game? Chemistry workbench still did not build with 51 save file.
  5. Cyjack

    Cyjack Member

  6. BillyBabel

    BillyBabel Member

    I'm still getting to a point where I get total gridlock in my carpentry workshop. I'm literally following wood that was cut down and watching wood added to my stockpile and then sitting there with nothing being done to it despite there being an order that is not a standing order for planks issued going unfulfilled .

    Attached Files:

  7. Nicholas

    Nicholas Technology Director Staff Member

    Let me have a look...
  8. Bluebird

    Bluebird Member

    Traders dropping goods off at wrong place again. And ceramics workshop now seems unable to build a brick kiln. Build the first ok, queued 2nd and 4 days later, still nothing. Deleted and tried again, still nowt. Are they just _really_ slow to make?

    Plus, twice a 2nd or 3rd mine worker wandered to the edge of the map to get "close to overseerer" or some such. Happy people so not just sulking.

    The good news is not one crash ... yay! Well done team.

    Attached Files:

  9. Cyjack

    Cyjack Member


    Don't know if this is known or not, but Macroscope, Vaccuum chamber, Iron Smelting Crucible , and a couple other high end Metal Shop items cannot be built even with maxed research and all ingredients. They don't break the module like some of the other problem items, but the job is simply ignored until you put another one in.
  10. Cyjack

    Cyjack Member

    @ Bluebird, that brick kiln just takes a long time to build for whatever reason. My last two games I thought it was stalled, it just took forever for them to build it. The situation is exacerbated if they are unhappy at all and their productivity is compromised. Watch what the person who is assigned to the job does in the morning after they've eaten. If they drop something off at it, you know they're working on it. They will occasionally decide to admire the stupid workbench for whatever reason, in between working on it.

    Make sure the module has the top priority spot in the queue, though. I did have a bugged shop last build where the lone ceramicist ignored anything not in the top spot.
    Last edited: May 23, 2016
    Bluebird likes this.
  11. Cyjack

    Cyjack Member

    51A Service-oriented buildings not performing as usual.

    I have a chapel staffed with an overseer with the spiritual quality, and the same sort of modules I always place in there. Usually colonists are always complaining that they want to confess but can't find a minister, and there are jobs lined up in the building menu. This game, I've yet to get a single job there. No one goes to the chapel, not even the minister assigned there.

    A similar building, the Public House, crashes repeatedly* when trying to assign a work crew there. I have reported this in the crash thread.

    * This was the only crash I experienced the entire playthrough on win 10. I really thought this was going to be the first crash-less game and felt terrible when it happened, but even so great work on the stability front.

    Attached Files:

  12. Braincooler

    Braincooler Member

    Here are some bugs that occurs today.

    I've received an error while trying to smelt steel ingot.
    Error : String FSM Support 221 : bad input fuel for job Make Steel Ingot (Update / Citizen).

    2. It's impossible to build the Iron Smelting Crucible too.

    3. The Public House crashes the game when choosing the workcrew (it's the old like from previous version).
    Last edited: May 23, 2016
  13. Bluebird

    Bluebird Member

    For #2, I've found these modules do indeed finally get made but can take a few days each.
  14. Wolg

    Wolg Member

    Crews assigned to farm are available in the list to be assigned to workshops. Is this an intentional change?
  15. Unforked

    Unforked Member

    I think it's always been like this, but the added UI functionality makes it more obvious. This is one thing that's going to annoy new players, because they'll accidentally assign their farmers to a new workshop, then wonder down the line why their farm isn't getting worked.
  16. Braincooler

    Braincooler Member

    All my workcrews are available in the list in all workshops, even the crews that are already assigned to another workshop... Don't you ? :confused:
  17. Unforked

    Unforked Member

    Just looked... By Cog you're right! Well that makes things even crazier. They used to disappear (except for the farm workers).

    In that screen there needs to be a way to determine who is already assigned. Unless there already is and I don't understand it.


    I see it now. The name of the workshop is under the name of who is assigned to it.

    I'm slow.
    Last edited: May 23, 2016
  18. Nicholas

    Nicholas Technology Director Staff Member

    Thanks for the saves, everybody. I think what will happen is we'll push another hotfix 51B to at least fix a bunch of the manufacturing stuff, but it won't happen until Tuesday due to Victoria Day up here in Canada. (Though pirates we, we love our Queen!)
  19. Bluebird

    Bluebird Member

    Thanks Nicholas. This is actually a really stable and enjoyable build. Not gone so long without major problems in ages. Great work there. Enjoy Pirate Day :)
  20. Mokkun

    Mokkun Member

    Had a crash, was just waiting while hoping my farms would make more food than my serfs were eating.. I really need to get the produce food part down.. ;)

    Attached Files:

Thread Status:
Not open for further replies.