Discussion in 'Clockwork Empires General' started by Nicholas, May 18, 2016.

Thread Status:
Not open for further replies.
  1. Nicholas

    Nicholas Technology Director Staff Member

    Seriously, there is and he is very annoying.

    Consolidated 50E changelog

    building materials now are picked up as a multistack
    module materials are also now handled as a multistack
    standardized job menu icons with work crew icons
    added ability to pause and unpause assignments via the assignment beacons
    added carpet to recommended modules for carpentry workshop
    redid the entire tutorial from scratch using the Event Arc system, it should be MUCH more intuitive now
    balance: made a few concessions for ease of food in the early game til we figure out how long it takes people to get through it in current version- improved yield from foraged food sources, and increased the food you get in the starter loadout
    (50D) added note to stone ceramics kiln that brick ceramics kiln is required to produce glass
    FIXED (50D): scripterror in favour_criminal
    FIXED (50D):"Smelt Copper Ingots" job error
    FIXED (50D): bricabrac icon
    FIXED (50D): scripterror in do_diplomacy_paperwork
    FIXED (50D): crash when accepting bandit to join colony
    FIXED (50D): cancelling building construction immediately crashes the game
    FIXED: "reverant" -> "reverent"
    FIXED: colonists will no longer attempt to use services of offices w/o assigned overseer or w/ off-shift overseer
    FIXED: characters spawning in the colony no longer have their ? alerts above their heads
    FIXED: combo box overflow in new workshop
    FIXED: multistack code would occasionally not find available building materials
    FIXED: gameSimAssignment::CancelAssignmentInternal crash when assignment is already cancelled or invalid
  2. Rahbek23

    Rahbek23 Member

    oh how I wish my work laptop wouldn't die horribly if I tried to run CE on it. It's itching in my fingers to get back home and try these new things out :D!
  3. Manamoo

    Manamoo Member

    Bug? When you open up the Work crew and get into the pop up windows showing their stats, the pop up windows remain open, no way to remove them. I am trying a restart right now. I tried the handy dandy escape button, didn't work.

    Also, the foundations are still disappearing. Kitchen this time, last time (see post in 50D) it was the Ceramics...Reload didn't fix it. It did, however, fix the above bug.
    Last edited: May 18, 2016
  4. Nicholas

    Nicholas Technology Director Staff Member

    Send me a save game with 50E where the fuondations are disappearing, though?
  5. So you can make wooden plinths, but you can't place them from the decor menu.
  6. Jacq

    Jacq Member

    The new tutorial is awesome. :)

    The stacking is also working pretty well. I think there should maybe be a limit to how much a single colonist can carry though, for a few reasons:
    1. Malcolm Cogswatter is probably not physically capable of carrying 64 blocks of stone at once.
    2. Construction of larger buildings (ie bunkhouses) is weird right now:
    - A colonist won't start gathering items until you have enough prepared in stock
    - Only one person starts each item, so a work crew of 3 people and an overseer has one gathering planks, one gathering stone, and 2 doing ???
    - For some reason the person gathering stuff wanders all over the map, instead of picking up the "next closest X" (wood/stone/etc)
    - A colonist will drop their stack of stuff on the floor to go eat or sleep. There's no guarantee that, tomorrow morning, they'll go to the huge stack of 50 wood first, or at all.
    I think a lot of these could be mitigated if each person could carry a max of 5/10/15 items (depending on item size/weight). That way, multiple people in a work crew could be involved with building stuff, you wouldn't have to wait until you chopped/mined/planked everything before getting started on construction, etc.
    Unforked likes this.
  7. Nicholas

    Nicholas Technology Director Staff Member

    1. Malcolm Cogswatter is Swole as Heck. I mean, just look at those muscles. Who are you to dictate what he can, and cannot carry? (But sure, yes, we could have weight if you WANT. I dunno. I'll tal kto the others about it in the morning.)
    2. Yes, although this is tentatively a feature: it fixes the issue where you have 3 blocks and 3 stone ovens to build, so everybody goes and puts one block in a stone oven.
    3. When the job is acquired, they pick up the closest X things from their *current* position, in order from closest to furthest, then haul them to the camp site. I am open to a better sorting metric. I don't want to re-evaluate the list of distances every time you finish picking up a good, but I guess I can.
    4. Okay, that's true. Hmm.
    Unforked and Jacq like this.
  8. Nicholas

    Nicholas Technology Director Staff Member


    what, yes, this is my third pot of coffee, what are you doing, I'm not stepping away from the keyboard
    Fluffeh, Mikel, Unforked and 2 others like this.
  9. Jacq

    Jacq Member

    There's an odd thing where people aren't intimidated by fishpeople trying to be intimidating. They'll continue to butcher/mine/etc (albeit very s l o w l y) while Missy Fishy throws a tantrum for hours.

    Attached Files:

  10. Got the "build a barracks" tutorial message, except it says I already did when I haven't even started on one.
    And the "tutorial finished" message popped up prematurely, as I hadn't finished my barracks or bunker house. Similarly, the "here are the controls" message seemed to show up much later than it should've.
    Last edited: May 18, 2016
  11. Jacq

    Jacq Member

    I am laughing too hard at Malcolm the Swole stompign around my colony throwing stones around and calling the overseers jabronis, btw. Expect a strongly worded letter at some point in the future.

    edit: But it is kind of a problem where if you're trying to, for example, make some planks n' cots (which take a little bit of wood), and also build a bunkhouse (which takes whole a lotta wood), where you never have quite enough resources to finish the big thing. This is easily solved by micromanagement, and the new "pause" system in the job menu is awesome for it. But it seems important enough to let people know it's a thing - maybe in the new shiny building tutorial? Personally it took me a good 10-15 minutes to work out why no one was constructing that building.
    Unforked likes this.
  12. Rentahamster

    Rentahamster Member

    My brick kilns refuse to make glass. Stone kiln makes bricks though. Demolishing and rebuilding the workshop did nothing,

    Also: Demolishing modules doesn't delete them from the workshop window.

    Attached Files:

  13. Manamoo

    Manamoo Member

    Here is the file where the foundation has disappeared. It shows the blueprint in the module...but as soon as you get playing the guys were walking, sleeping and even building the building in mid-air. I thought maybe after the actual building was built it'd show up, that didn't happen. Dunno...was happening in 50D as well.

    Attached Files:

  14. dbaumgart

    dbaumgart Art Director Staff Member

    Logged as OC-4805! Thanks for the report. Can't promise it'll get fixed super fast due to being pretty minor.

    Logged brick kiln/glass as OC-4806.
    Logged demolishing modules issue as OC-4806.
    Thx for the reports!
    Jacq likes this.
  15. Rentahamster

    Rentahamster Member

    Eventually my brewing vats and power saws crapped out too in a similar fashion.
  16. Wolg

    Wolg Member

    Stalwart Supply: despite being assigned to the NCO's squad, the starting militia is ? marked; unassign and reassign makes it go away.
  17. Alephred

    Alephred Royal Archivist for Queen And Empire

    Military NCO replacement is still not working properly; when the Overseer of a Military squad dies a grisly death, the first colonist in his employ moves into the Overseer position, and the Crew retains its military name, BUT he does not become an NCO (militia or otherwise), and the remaining commoners do not remain soldiers. Furthermore, the resulting Crew cannot be assigned to any workshop at all, barracks or otherwise.

    MOOMANiBE Ah, those were the days. Staff Member

    Ah, yeah - We were only checking that you assigned someone to a military workcrew. Added a safety check that makes sure you're assigning someone to a military workcrew based out of a barracks for next build.
    I'm... not sure what might have caused this, other than the previously mentioned bug. Lemme know if you have any more details.
  19. Rentahamster

    Rentahamster Member

    @devs I don't suppose you guys have a suspicion at what actions or chain of actions cause modules to stop working? So that I can try to avoid that if I want to play before the next experimental comes out.
  20. Teutomatos

    Teutomatos Member

    Failed in Stockpile icones ( logs image )
    Last edited: May 19, 2016
Thread Status:
Not open for further replies.