Discussion in 'Clockwork Empires General' started by Nicholas, Apr 15, 2016.

  1. Nicholas

    Nicholas Technology Director Staff Member

    It's up on Steam! Changelog here:

    Including our internal test alphas before launch, this is Alpha 50. Crazy, huh.

    Changes since 49C:

    - fixed a bunch of memory leaks
    - fixed a bunch of load/save crashes
    - fixed a bunch of script errors

    (Fences and Daniel's new alert system, Phase 2 did not make it in but will be in for 50A. Please look forward to it.)

    (Does anybody know why the Alpha 50 tag is blue?)
  2. dbaumgart

    dbaumgart Art Director Staff Member

    PartTimeVillain, Viion and Unforked like this.
  3. berkstin

    berkstin Member

    Does this patch address the "worthless lumps of NCO" issue?
  4. Wolg

    Wolg Member

    I think David already said yes elsewhere, though I didn't see it in the changelog...
  5. Alavaria

    Alavaria Member

    A special anniversary number 50!!!
  6. Viion

    Viion Member

    Always did wonder what that guy were doing on the history channel :-D Oh, sorry... the "History" channel *cough*

  7. Selly1

    Selly1 Member

    The issue of the cursor not selecting the thing under it still exists. Any news on when that's due to be looked at?
  8. bruteboy

    bruteboy Member

    Hi guys i just bought the game and have watched a couple of gameplays on youtube. However, i am having trouble finding the maize farms and i can only build chili, tea and sugarcane fields. How do i access the other farms?
  9. Unforked

    Unforked Member


    Your starting crop now depends on the biome you chose on the world map. Certain biomes will start you off with only maize, for example. In order to unlock more, you have to build a laboratory and research new crop technologies.
  10. For some reason, one of my crop fields has vanished visually. It still works, it's just invisible so it looks like my chilis are growing out of the grass.
    EggsAckly likes this.
  11. Nicholas

    Nicholas Technology Director Staff Member

    Ugh. It *shouldn't.* Grr. Can you please send me:

    - video card
    - resolution you are playing the game at
    - fullscreen or windowed?
    - desktop resolution

    and we'll see if we can come up with something?
  12. Kelian

    Kelian Member

    I for one am not a fan of bandits being able to demolish or damage my buildings with their fists. This is extremely frustrating... Explosives fine, melee attacks/bullets not fine. Ugh.

    Also just tried the Tundra biome, only cabbage and flax... life is tough.
  13. Alavaria

    Alavaria Member

    I think desert is worse, you might have no trees on top of it.
  14. Unforked

    Unforked Member

    Desert plus dauntless dare is a fun challenge.:)
  15. Wolg

    Wolg Member

    Might be jumping the gun on work in progress, but I don't like the top left positioning for alerts given the panels hide them when open (and I leave the jobs list open a lot).

    Could it also at least play an appropriately Clockworkian bell when an alert pops? Most of the time when I see an alert its burn bar is already over 50% gone...
    Selly1 and Unforked like this.
  16. bruteboy

    bruteboy Member

  17. Selly1

    Selly1 Member

    - video card: GeForce GTX 970

    - resolution you are playing the game at: 1920 X 1080

    - fullscreen or windowed?: Fullscreen

    - desktop resolution: 1920 X 1080

    I've attached a scrfeenshot of the region I saw this in (a very hilly one). And finally, the issue seems to have fixed itself with a reload. I've had a couple of other minor bugs fix themselves with reloads (like only one worker working in the foreign office at a time).


    Feeling a little silly now it's vanished on its own!
  18. Rahbek23

    Rahbek23 Member

    Don't feel silly! If the devs don't know about a problem, they'll never be able to fix it :) Sure it's not a huge problem per se, but it could be a symptom of faults in the renderer or something that would be nice to get fixed before release!
  19. I find this revision extremely difficult and I don't think it's intentional.

    A few issues I've come across;

    1. NCOs don't respond to a rally call.
    2. If a workshop is destroyed while it has an overseer assigned to it, the overseer cannot be appointed to a new workshop and will forever be unavailable for other workshops.
    3. I've had bandit raids with no warning, which wouldn't be too much of an issue if it wasn't for;
    4. The bandit raid is significantly larger than my military and
    5. The military is pretty ineffective generally. Since they don't respond to rally calls it is pot luck whether all soldiers get into combat, or they lemmings-style walk one at a time towards the enemy only to be killed by multiple enemy combatants.
    6. Once your NCO dies it is pretty much game over. I've literally had 1 bandit wipe my entire colony as the colonists just panicked and ran from combat (despite carrying weapons). It would be useful to have a "last resort" option where if you have no barracks or NCO you can force normal colonists to enter combat with significant unhappiness as a result.

    Despite these issues with combat and dealing with early threats the game is coming along nicely and is sucking me back in after quite a long absence so hats off to you guys.
  20. EggsAckly

    EggsAckly Member

    -can't reload anything without a crash just lately
    -an unfinished building took only one punch to be destroyed , then caused a total freeze up
    -sometimes can't undo forbid or designate as trade
    -sometimes a beetle will wander around forever and never get hunted with hunting on and the hunt order given
    -also don't like that the pop ups are now hidden under the drop down
    -I had traders show up empty handed , they wouldn't leave even when I gave them some free stuff , until I demoed my trade office
    -bamboo doesn't count as a log if you're starting a new building and have no real logs
    -when people are foraging due to starvation they'll forage lacquer

    -a mini-map finally thanks , be nice to be able to use it to zoom in
    -rename workers option would be nice if it worked
    -tea takes a ridiculous amount of labor