Windows 8 64-bit After fresh install, Dungeons of Dredmor crashes after launching

Discussion in 'Bugs' started by Kaidelong, Apr 24, 2014.

  1. Kaidelong

    Kaidelong Member

    MSVC++ gives me a useless dialog saying there was a runtime error with no further information other than "contact support". Various permutations in the launcher don't seem to change the situation at all. Opting into the beta doesn't help either. I reinstalled DoD because it was unable to save new games anymore, but it not working at all is even worse.

    I suspect that the problem might be that Dungeons of Dredmor is broken upstream on Steam's end, at least the windows binary is.

    In somewhat related news, I've lost all my files for Arctic Foods and Charmed Fletcher. Sad.

    I would ask people to replicate but given that they might break Dungeons of Dredmor entirely, that seems a little much. Steps to replicate:

    1. "Delete local content" in steam, uninstalling Dungeons of Dredmor.
    2. Reinstall Dungeons of Dredmor.
    3. Dungeons of Dredmor crashes after pushing "Start Game" in the launcher
    Exile likes this.
  2. rydash

    rydash Member

    I was not able to reproduce this following these steps. Then again, I'm on Windows 7. Not sure if that has anything to do with it. I'm assuming you tried verifying the game cache integrity and all that jazz?
  3. Daynab

    Daynab Community Moderator Staff Member

    Could it be somehow missing the Visual C++ redistributable? that's the only thing I can think of. But I'm not sure if there's a way to check.
  4. Nicholas

    Nicholas Technology Director Staff Member

    Anybody else having this one?
    Exile likes this.
  5. Kaidelong

    Kaidelong Member

    It passed validation. If only it worked any better from that.
    Exile likes this.
  6. Bohandas

    Bohandas Member

    Have you scanned your computer for viruses?
  7. Kaidelong

    Kaidelong Member

    Well given that I might as well try anything I did, nothing showed up.
    Exile likes this.
  8. Kaidelong

    Kaidelong Member

    Okay so I figured out what happened. After my old Documents\Gaslamp Games\Dungeons of Dredmor was deleted, the game regenerated a new config.xml. For some reason, although I had steam cloud disabled, steam cloud integration was set to 1. This caused the game to crash on loading. An error message would have been nice.
    Exile likes this.