Windows Vista/7 64-bit 1.0.8.digglegods bugs.

Discussion in 'Bugs' started by Neviskio, Dec 15, 2011.

  1. blob

    blob Member

    Same issue though as early as floor 2.
    running on win 7- 64 bits.
  2. Copycat Zero

    Copycat Zero Member

    I blocked an attack from a Fish Paladin. The combat log said it hit me for 10 Righteous damage, the floating damage text said 5. One assumes the combat log is wrong.

    On the subject of "things appearing where they don't necessarily belong", I found a "Dwarven Express Post" room with a Satanic Displacement Glyph right where one of the three Chests of Evil would appear. Obviously, once the chest was opened, there was no issue, but it still doesn't look very good. Maybe there is a way, in those sorts of scripted rooms, to tell the game "Don't spawn anything in these three spaces"?
    [EDIT] In one of those "five teleporting levers to get around" rooms, one of the teleport levers was placed exactly in the spot that another one teleports you to. That's the first time I've seen that happen.
    [EDIT 2] In another "Dwarven Express Post" room, one of the Chests of Evil would have spawned on top of another chest (had I not opened that chest first).

    Is it intentional that Transmutationer can turn normal gems (sapphires, etc.) into things like Runes of Difference (which are flagged as gems)?

    The Axe of Dinglenit apparently has no value, as Brax is selling it for 0 gold.
    [EDIT] Speaking of Brax, you can still quick-sell items he would refuse to buy if you clicked on him with it (like Horadric Lutefisk Cubes).

    The area of the screen blocked by the new crafting interface is larger than its actual appearance would imply. I've got my Horadric Lutefisk Cube window placed adjacent to the upper-right side of the crafting window, and I can't click on or drop anything into the Cube.
    [EDIT] Also, due to the change in the way crafting is handled (i.e., the ingredients are taken directly from your inventory), using up a material when your inventory is full will still give you the "Your inventory is full" message and drop the item at your feet, even though you just freed up a slot by crafting the item. A minor inconvenience, but still.

    Confirming the other reports that you can get Blood Magic procs off the monster types the skill specifically says you can't (like undead).
    [EDIT] Speaking of monster types, I'm somewhat surprised that Octos are considered "animals" rather than, say, "demons".

    I somehow contracted Diggle Plague when there were no diggles (plagued or otherwise) involved in the fight. It may or may not have been cast on me by Jiggy Gnomes. Also, said Jiggy Gnomes placed a Putrefying DoT on me that had no debuff icon.

    The description of The Most Dangerous Game should probably say "This skill grants you more Butcher and Trophy Collector rewards." to conform with the skill names rather than "butchery and Grisly Trophy" (although I do see the proc is actually called "Grisly Trophy").
    [EDIT] On the topic of Big Game Hunter, is Release the Hounds supposed to spawn a variable number of Trained Hunting Diggles, or is it always supposed to be four? Because I've summoned only two or three on a few occasions now.

    Plunder appears to be nonfunctional.

    I found a Haematic Phylactery as a random item on the ground. Drinking it appears to have done nothing.
  3. Godwin

    Godwin Member

    Were you full health? It heals about 50 hp.
  4. Copycat Zero

    Copycat Zero Member

    Unless the misspelling is intentional, it should be "Bonsai Bomb", not "Bonzai Bomb".

    Much like the new bolts, the new throwing weapons aren't sorting to the same place as the old ones.

    Something that's been in the game since when you all changed the hidden status of a few of the recipes, but it's a bit strange that the recipe for Jingly Jangly Staff of Crystals is visible by default, but the recipe for the noticebly weaker Staff of Immaculate Conceptualization isn't (above and beyond the issue that the Metal Orby Staff recipe isn't visible either, meaning that you can't even make either of the other two by default).

    Using a wand in batty form, much like doing so in werediggle form, momentarily reverts you to human form for the animation.

    And, speaking of willing polymorphs, it would be nice if there was the option to cancel the buff and revert without waiting out the duration.

    Something I've only noticed during this run, but, sometimes when I kill multiple enemies at once with Tenebrous Rift (like in a Zoo), my sound goes muddy for a couple turns. Specifically, it seems to be occuring when the death sounds coincide with the "you've got a debuff now" sound (or maybe with the "Haywire!" voiceover).

    Sparkly doesn't appear to be giving any life back.

    This has been in the game for as long as fleeing enemies have, so it's not unique to the Coward AI, but, it seems a little unfair/weird that fleeing/Coward enemies should be able to move diagonally when nothing else in the game (including the player) can.

    When I get the Spirit Conduit proc, the monster will have stars over their head but will still be able to attack me (with the stars graphic remaining on them). This doesn't always happen.

    That would account for it, yeah. I had assumed that it would put some sort of "Resurrect me the next time I die" buff on me.
  5. klaymen_sk

    klaymen_sk Member

    So far I've encountered these bugs in RotDG:
    -no DLC-related achievements are working. Yes, some people wrote that maxing the Piracy skill tree got them another achievement, but I got nothing. Vanilla game achievements are working, though (I got Kleptomania and Perception maxing achievement without any problems)
    -in the last save, after walking into certain room I will get teleported somewhere else. Then, after doing anything (moving, using a skill, or skipping a turn) I get teleported to another room and then back, effectively making the game unplayable from that point.
    -maybe it is a bug or intended, but after using "Release the hounds" skill to summon four hunting Diggles, I can attack and kill them for experience.
    -butchery gives meat from any monster type, not only animals.
  6. Copycat Zero

    Copycat Zero Member

    I was attacked by walking adjacent to a monster that was listed as "not notic[ing] [my] presence". I believe, a little earlier in the level, I also had a Flame Golem that hadn't noticed me cast its AoE fire attack on me.

    Much like several of the other new monsters, Sparkies don't appear to leave visible corpses behind.

    They posted a hotfix for that issue in a recent blog.
  7. klaymen_sk

    klaymen_sk Member

    Yep and now the teleporting levers in the room with five of them and a moat in the middle don't work at all. At least yesterday they did not when I tried continuing in my save which had the teleporting bug before.

    EDIT: I have found another room with five teleporting levers and they don't work.
    Also I have found the room which did the teleporting bug and it happened again. And fresh character did not get those bugs, so I guess this character is borked anyways.

    EDIT 2: The Steam overlay (Shift+Tab) seems not to work. I'm not sure if it worked before the patch, though.
  8. Copycat Zero

    Copycat Zero Member

    Steam overlay has never worked with the game, except, I think, if you put in a command line thing (-opengl ?).