1.0.7 on Ubuntu 11.10 major instabililty

Discussion in 'Bugs' started by dpiekny, Nov 29, 2011.

  1. Dean

    Dean Member

    Just to say, I'm running arch linux and as of yesterday was having the same problem, segfaults at random points. This was on my desktop with an nvidia card, and was unable to replicate on my netbook with some intel card. So I thought it might be some gfx card thing.

    That said, I played around with the dredmor/x86 folder and it now seems to not segfault (although it may just be a matter of time before it happens again, but I actually managed to clear the first level and it did not segfault at any point).

    I backed up the .so files and replaced them with links to the .so files I already have in /usr/lib/ so something like:
    cd /PATH/dredmor/x86
    mkdir backup
    mv * backup
    ln -s /usr/lib/libgcc_s.so.1 libgcc_s.so.1
    ln -s /usr/lib/libSDL_image-1.2.so.0 libSDL_image-1.2.so.0
    ln -s /usr/lib/libSDL_ttf-2.0.so.0 libSDL_ttf-2.0.so.0
    ln -s /usr/lib/libSDL-1.2.so.0 libSDL-1.2.so.0
    ln -s /usr/lib/libSDL_mixer-1.2.so.0 libSDL_mixer-1.2.so.0
    ln -s /usr/lib/libstdc++.so.6 libstdc++.so.6
    As I said, it seems to work at the moment, but I haven't tested it for more than about 20mins. Also I have just done a system upgrade so that could have fixed it! Let me know if you want any more details.
  2. Tuxedo

    Tuxedo Member

    Same thing as everyone on this thread, with Kubuntu 11.04 32 bit.
    I look forward to play this game, the only one that made me buy the bundle (I already have aquaria ) ! That's quite a disapointment
    And as someone asked before, if the 1.0.7 can't be fixed easily, could we have the 1.0.6 to downlaod on the humble bundle site ?
    One of the point of buying a game that runs on linux is tha I don't have to instal and run steam on wine...
  3. ColdSpider

    ColdSpider Member

    Just wanted to add my name to the list, I'm running it in Linux Mint 11 LXDE, though it sounds like it's pretty much happening to everyone regardless of distro. I'm not getting any error messages or anything, it just closes out randomly and I'm fairly useless with the terminal so I have no idea how to debug it (or even run it) that way, I'd be happy to do that if someone can tell me how.
  4. kasi

    kasi Member

    This is where it crashes for me: going from Level 2 to Level 3.

    This is the trace:

    #0 0x000000000054a199 in PHYSFS_read ()
    #1 0x0000000000484aae in Sprite::Load(char const*, char const*, int, int, int)
    #2 0x00000000004c55d5 in LoadTintedSprite(char const*, int) ()
    #3 0x00000000004c5716 in Monster::TintSprites(int) ()
    #4 0x00000000004c5ab9 in Monster::RebuildSprites() ()
    #5 0x00000000004c82ee in Monster::Monster(monDBEntry*) ()
    #6 0x000000000045b9bc in Level::SpawnHorde(int, int, Quest*, char const*) ()
    #7 0x000000000041dab2 in Level::WriteDungeonContentFromRoomRecords() ()
    #8 0x00000000004227ab in Level::GenLevelContent1(int, int) ()
    #9 0x000000000045f051 in Level::GenLevelContent(int, int) ()
    #10 0x0000000000410539 in Descend(int, int, int) ()
    #11 0x0000000000495410 in Stairs::SteppedOn() ()
    #12 0x00000000004f4f32 in DoSteppedOn() ()
    #13 0x00000000004ffcc3 in ParsePlayerInput() ()
    #14 0x000000000049231f in Mainloop() ()
    #15 0x0000000000493ad8 in main ()
  5. Toby

    Toby Member

    Using psychic shove or a handy want causes the game to freeze every time. Ubuntu 11.10 x64. The game freezes or crashes so often that it's basically unplayable.
  6. xolotl

    xolotl Member

    FYI, this one in particular looks like the issue described over here: http://community.gaslampgames.com/threads/statue-of-inconsequentia-crash.1318/

    There's a patch in that thread which should probably take care of it for you. In Level 3 specifically is where I started running into the monsters that were affected by this bug; I'm guessing that the folks experiencing problems right at the beginning are encountering some other issue.
  7. Nicholas

    Nicholas Technology Director Staff Member

    The problem has been found, and we have heaped verbal abuse upon the culprit.

    Patch on the way.
  8. Nicholas

    Nicholas Technology Director Staff Member

  9. Loren

    Loren Member

    I'll test it after work (~2hrs) if no one else can get to it before then.
  10. Tuxedo

    Tuxedo Member

    I tried to run the patch, here is what I got:
    dungeons of dredmor: version 1.0.7
    argv[i]: ../Dredmor-x86
    SDL version 1.2.14
    Segmentation fault
  11. Nicholas

    Nicholas Technology Director Staff Member

    Don't run the patch directly; run the shell script.
  12. GrossorMD

    GrossorMD Member

    Do we unpack it directly in the dredmor folder?
  13. Nicholas

    Nicholas Technology Director Staff Member

    Yep. It should overwrite the two files that are there. Then just run the game by running "./Dredmor" as per usual.
  14. For me it works!!!.. at last i can play longer than 5 minutes!!!

    Thanks Nicholas!.
  15. Tuxedo

    Tuxedo Member

    OK sorry for that, it does work once you use it properly ;)

    Edit: And thank you for this patch
  16. fana-m

    fana-m Member

    Hey, just found this patch, hope it works ^^
    Didn't made some longer tests.
    The only thing i've tested where the summon wyrmling spell and it still crashs the game

    Dredmor-amd64: /home/${USERNAMEOFTHECODER}/dredmor/monster.cpp:400: Monster::Monster(monDBEntry*): Assertion `(entry->level - curLevel->number < 4) || entry->name == "Brax"' failed.
  17. GrossorMD

    GrossorMD Member

    So far so good. I'm not crashing for the moment. I can't speak for late-game bugs like the wyrmling bug above because I've not gotten that far.
  18. akurtz

    akurtz Member

    That seems to work, although I've had a few crashes when picking up sidequests.
  19. Loren

    Loren Member

    The patch helps quite a bit. From my initial testing, handy wands and bombing oneself do not cause crashing anymore. I'll test it out further tonight.
  20. Twig

    Twig Member

    Seemed to make a bit of difference but the game crashed when I tried to use a quest item on a monolith :(