1.0.7 Beta Bug Thread

Discussion in 'Bugs' started by Copycat Zero, Nov 7, 2011.

  1. Just ran into a crash trying to imbue some gloves with an anvil I had restored power to. The gloves already had a few enchantments as they were a reward for finishing a quest. I tried using them on the recharged anvil and what you would normally expect to happen did. It showed me the menu with the stats that had been added (-2 to hit -2 to crit) as well as the previous enchantments, then the whole game shut down and the game window wouldn't respond.

    I'm going to try imbuing more gloves to see if I can find out exactly what was causing the crash
  2. Copycat Zero

    Copycat Zero Member

    Welp. That save is borked completely, it turns out. Tried loading the save with the mod enabled (tried loading the save with both versions of the mod enabled, first, and then with just the later version), and the game crashed immediately. But it was the "Windows has encountered a problem and is shutting the program down" kind of crash, rather than a hard-crash to desktop, and it's not generating a crash log.

    I'll e-mail the saves and the mod files to the Gaslamp guys.
  3. Essence

    Essence Will Mod for Digglebucks

    OK, so my previous screenshot was the result of ign'ance on my part. I thought when you modded the skillDB, you had to have all of the old text still in there. I didn't figure it out until I started poking at pokeball; thanks for that! :)

    But, the problem still exists to a degree:


    My first skill, QiGong, shows up correctly after the 'random' button in the inital skill-list, but my last two skills still take over the Last Pick and Random buttons below. I suspect they've been programmed to take over the last two skills in the list, which are usually Last Pick and Random, but not when you've got new skills modded in. :)

    [EDIT: Wow, this causes a lot of problems.

    First, the "Random" button (in the skill list up above, not the bar) can randomly choose "random" or "last pick" as active skills. It seems, though, as though the game 'fixes' this by instead giving you whatever modded-in skills come after "random" and "last pick" in the skill list. If, however, you end up with both "random" and "last pick" on your choices list, the game crashes when you hit "done".

    Second, you are forced to take the two skills in the "random" and "last pick" squares on the bar. If you happen to pick one as an active skill you want, you get it normally, but if it overwrites one of your chosen active skills, then you see the icon for the modded-in skill in your skilltree, but no skills come after it and you've basically wasted 2 of your picks. Furthermore, if you choose the "last pick" skill, but not the "random" skill, the "random" skill will break the "last pick" skill's skill tree anyway just to be spiteful. If that makes no sense, just ask and I'll say it with screenshots.

    [SECOND EDIT: I think. I've been toying with it some more and the more I toy with it the less sense it seems to make.]

    Needless to say, skill modding won't really work until this gets fixed. :)]

    Also everything in the ItemDB called "greaves" should be switched to the Pants slot.
  4. Eikre

    Eikre Member

    Can you zip up the mod that you're trying to run and upload it? Wanna dick around with it a little.

    Simple one here detected by IRC dude goober: The "Vampirism Attack" Krong enchantment isn't working. The problem is on line 322 of the itemDB.xml, which refers to a spell called "vampirism"; the such a spell doesn't exist. The spell should be "Vampirism Attack" instead, probably. Easy to fix.
  5. Essence

    Essence Will Mod for Digglebucks

  6. Eikre

    Eikre Member

    There is an error at line 4 of your templatedb.xml, where you are missing your close bracket. So you can fix that.

    I am additionally sorting through your skillDB and I've come to the conclusion that it needs some work too, I will get back to you on that. Point is, Gaslamp, don't go chasing after ghosts, yet.
  7. Essence

    Essence Will Mod for Digglebucks

    Yeah, I'm an amateur coder (like, this is my first time ever.) But I use Opera to parse the XML, so I know the code part is solid. (I had just changed the Template file when I uploaded it.)
  8. Essence

    Essence Will Mod for Digglebucks

    Mind the double post.

    Magic Training is failing to loadout the Cracked Orb because it's trying to loadout an "armor" named Cracked Orb. Cracked Orb is type="shield". :)
  9. Just started a game with a mage build and didn't get ANY starting equipment other than a robe on my character. I took Astro, Necro, Magic Training, Promethean, Golem, Blood mage, and Burglary.
  10. Eikre

    Eikre Member

    Not in the context of skillsDB, Essence. It's as it should be, in that regard, but it is missing the entry always="1", just like Fleshsmithing's offal and Blood Magic's sacrificial dagger. How do other skill loadouts function correctly without always="1"? It is a mystery, but some skills need it added.
  11. Essence

    Essence Will Mod for Digglebucks

    Yeah, I just edited them all in. :)
  12. After further testing, it appears that the sprite for broken reused Krog anvils is missing. It causes the game to crash any time I use a recharged anvil.
  13. Nicholas

    Nicholas Technology Director Staff Member

    Fixed a bunch of disappearing-item bugs, and the toolkits not launching from the new hotkeys if they're in your belt. Looking into the other stuff now...
    Essence likes this.
  14. Nicholas

    Nicholas Technology Director Staff Member

    - fixed the Anvil crash...

    EDIT: Fixed the skill modding problem, although not the mystery of the vanishing scrollbar. Fixed the cracked orb not showing up if you select Magic Training, and general problems with certain skills not getting what they ought to start with. Fixed DoT effects. Added some new fun to the text ticker. Fixed, finally, the transmutation of gems. Fixed a bunch of stacking consistency issues.... fixed all sorts of things.

    We'll do a new beta this evening or tomorrow morning.
    Marak, brobbeh and Essence like this.
  15. Essence

    Essence Will Mod for Digglebucks

    Shift no longer quick-sells, it just drops items at your feet. :(
  16. On top of this my game still crashes after using recharged anvils. I also seem to be getting +2 explosive damage against ONLY batties for some reason.
  17. J-Factor

    J-Factor Member

    It seems the devs are testing negative resistances and have only applied them to Batty monsters.

    All Batty type monsters have the following (double the numbers for Lil' Batty):
    <resistances crushing="-1" slashing="-1" blasting="-1" />


    amountF doesn't work for healing. Example:

    <effect type="heal" amount="1" amountF="0.25" />

    This will always heal 1.
  18. 123stw

    123stw Member

    Lol that amountF thing were there since forever.....
  19. Essence

    Essence Will Mod for Digglebucks

    Regarding the modloader: it won't 'forget' old mods. I upgraded the mods I've been playing with, and I changed their revision numbers in the mod.xml in addition to the changes to the game files. The modloader's response was to duplicate the entries -- creating new entries for the new revision, but not deleting the old entries. So now I have five mods listed, "Essential DoD Skills", "Essential DoD Skills II", "I Want To Be The Very Best", "Essential DoD Skills", and "Essential DoD Skills II". The last two I'm pretty sure are the entries with the previous revision numbers as the first two, and they don't actually exist -- picking them does the same thing as picking the first two.

    Nevermind, I'm a moron. I just had folders that were exact clones of the zip files but weren't zipped, in the same directory. I assumed the game only looked for zip files, but when I moved the non-zipped folders elsewhere, the duplicate entries vanished. My bad. :confused:

    I'd also like to suggest that the modloader show version numbers for mods somewhere.

    Finally, it seems like (and I may just be an idiot) there's a problem loading modded item art. I've added a couple of items in my main mod, and the first time it loaded up, it said "Cannot load art sword_venomous_stiletto.png. The game will now crash." and "Cannot load art thrown_dart_poisonous.png. The game will now crash." --- but then it finished loading and worked fine, and it hasn't done it again. It's just that first time through that gave me the panic.
  20. Copycat Zero

    Copycat Zero Member

    It's an existing bug that Unarmed is added its damage to ranged attacks to, right? You can see it in Essence's screenshot in the other thread, and I've got a character now who also has it.

    Speaking of my new character, I'm Unarmed/Shields/Dodge/Vampirism/Viking/Blood/Archaeology. I started with a Sacrificial Dagger, but NOT with a shield. Is this normal starting item behavior or a bug (I know that me not starting with a Hachimaki is normal)? [EDIT] Traded in Viking and Blood for a couple more Rogue skills. Still no shield.

    Crafting tools, or at least the ingot press, still aren't splitting.

    Vampirism now isn't healing at all on kills, as opposed to only healing 1.

    Confirming that shift+click in stores doesn't do the quick-sell behavior.