1.0.7 Beta Bug Thread

Discussion in 'Bugs' started by Copycat Zero, Nov 7, 2011.

  1. Copycat Zero

    Copycat Zero Member

    Well, one right off the bat: Alchemy is, for whatever reason, starting with a Smithing Kit rather than an Ingot Grinder. [EDIT] Or, maybe not. I died and restarted with the same skills, and this time I spawned with 3 Diamonds instead (but still no grinder). And the time after was 3 Saltpetre (in addition to the Aqua Vitae, Aqua Regia, and random potion I've been consistantly spawning with).

    Speaking of the Ingot Grinder, I notice that one of the recipes for Grated Cheese (the one between Parmigiano and Gouda) has nothing in the ingredients slot.

    When you try to change abilities from the belt, Lucky Pick isn't showing up on the list of options. I've got Deathly Hex and Lucky Pick right now. Lucky Pick shows up on the belt just fine, but if I try to change which ability is assigned to which key, only Deathly Hex shows up on the list. Having gained a level, I see that Drinker of the Dead also isn't appearing.

    Also, Lucky Pick doesn't appear to be granting the +1 Trap Sense; I still have the default 1 TS on the character sheet and I'm definitely locating traps as if I had 1, not 2. Neither is Rogue Archeologist... indeed, I don't think any of the skills are adding their passive stat bonuses.

    Somehow, the on-field sprite for the girl looks like she has less face than the guy does. Maybe I just haven't looked closely enough at the guy...? [EDIT] Nevermind, just never noticed that the guy's mouth was missing too. The girl's nose is higher, which makes it more noticeable.

    Also, this:
    The result of me clicking skills at random after I noticed the game doubling-up on Vampirism the first time.
  2. marsgreekgod

    marsgreekgod Member

    Glich: when useing knightly leap as female, you turn into a male

    Oversights: As a female the level up screen still shows a male.
    The propganda posters still talk about males on the frist floor
  3. Copycat Zero

    Copycat Zero Member

    Weird, the one level-up I managed to get as a girl had the girl on it. So maybe it is a bug, rather than an oversight.
  4. marsgreekgod

    marsgreekgod Member

    I've leveled up two times and it was male each time.


    I did really like the way she holds her hand in the air though
  5. Eikre

    Eikre Member

    I just found a ring worth negative several million Zorkmids but neglected to gather a screenshot or buy it because I wanted to take a save first. Saves are broken, needless to say, but I'll keep an eye out for it in the future. I feel like this is a bug that's cropped up before, though.

    Probably relating to the larger problem with healing over time is that the Coral Wands and Fairywodger health regen effects don't do anything. It's a good bet that Lively Regeneration potions are useless, too, but I haven't gotten my hands on one yet. Yeah lively regen is broke. You still get the initial healing from popping the wodger.

    Even though Vampirism is broken, Blood Magic seems to work just fine.

    The level-up fistpump is too cute, and consistently removes the player from the hyperlethality-induced state of dismay. You may wish to change animation to something more conducive to the destruction of the player's self-worth.
  6. Dicky B

    Dicky B Member

    1. Froda's jump discontinuity uses the male animation if you are female
    2. I sold something and my gold went down to some extreme negative number. Like negative 9 million-and-something. I can't remember what it was I sold but I'll send in a save file next time it happens.
  7. Eikre

    Eikre Member

    Further Tales of the No Good Dirty Rotten Lying Character Sheet: If you equip an axe without having the Axes skill, the charactersheet will report that you deal an extra 1 slashing damage, which I feel is probably related to the damage bonus awarded by Combat Lumberjacking. Just like in patch 1.0.6, you can put the weapon in your left hand to be additionally credited with the bonus on ranged damage. I imagine a person without Maces is reported as dealing an extra crushing damage, too, and I'll test that once I get the chance.

    The actual damage dealt in combat, however, seems consistent with the correct values.

    This new thing where items go directly into your bag instead of your cursor, whenever you finish a quest or open a chest? If your inventory is full they just poof. Predictable.
  8. Eikre

    Eikre Member

    Welp the "click to add skill" interface is broken, you can't change your skills from the first ten you learn. Hope you guys weren't planning on using more than one school of magic!
  9. [​IMG]

    Lol, the skill bug can go on forever, funny thing is, I never selected vampire at any time, and even after removing all the main skills, the 4-5 clones were still there
  10. Copycat Zero

    Copycat Zero Member

    Well, Alchemy is starting with the right tools, but the wrong spare ingredients. I've got 3 voltaic cells, a spring-loaded power core, and 2 black pearls (which are useful to Alchemy, yes, but seem more like they're begging to be ground into chalk to make steel out of). [EDIT] Ah, wait, there are my aqua vitaes and aqua regias already in my bar. So I'm starting with a bunch of excess crap in addition to my craft's stuff. On my next start I had a blacksmithing kit, an argentite, and 3 aquamarines.

    Is it an intentional nerf that all of the booze recipes now cost double the ingredients (other than the aqua vitae ones and Slivovitz, which all cost the same)?

    Health regeneration doesn't quite seem to be working right yet; or, at least, a potion of lively regeneration only restored 5 health to me (2 right off the bat and the other 3 over the entire duration of the potion). Also, Vampirism is still only healing 2 points a hit, unless that's intentional. [EDIT] I gained some magic power and it went up to 3 points a hit, so I guess the starting healing was nerfed a bit?

    Getting the male level-up portrait as a girl, although I've sworn I've seen a female one once.

    As Eikre reported, evening though I don't have Axe skill, equipping a crude stone axe in my right weapon slot is making the melee attack field show 3 Slashing instead of 2, and equipping it in my LEFT slot is doing that and having 1 Slashing appear in my ranged attack field. Doing it with a nailboard is doing the same thing, but with Crushing damage.
  11. Nicholas

    Nicholas Technology Director Staff Member

    Yes, the nerf is intentional. The high level boozes give more mana, so it's not a total nerf, but it's ... ehhhhh.

    The random stuff is amusing! I just need to get it from the right categories. Most of the time.
  12. Copycat Zero

    Copycat Zero Member

    I can kind of understand the nerf (much like the distilling nerf from the last patch), since someone with a fruitful staff, which is easily obtainable on Floor 1 if you rush the Alchemy, can get quite a bit of booze by the lower floors.

    Nothing inherently wrong with the random stuff, since the regular stuff is still there. It just seemed like a bug because of how weird it was.

    More stuff:

    Related to the aforementioned weapon issue, I'm getting 1 Piercing damage from nowhere. None of my gear has it on it, my skills are Dual Wielding/Artful Dodger/Master of Arms/Deadshot/Vampirism/Burglary/Archaeology, so none of them are adding it, and it's still there whether or not I have my weapons equipped. Also, when I put on my 1 Piercing damage crossbow, the ranged attack field shoots up to 4 Piercing for some reason.

    Seconding 123stw's note from the main beta thread about skills being unchangeable in the action bar.

    The keybinding options are showing "Hidden Level Boost" and "Hidden Trapdoor" options, presumably from the prerelease beta? (Un)fortunately, neither of them work.

    Still not fixed. I used Knightly Leap on one occasion and a Spacial Distortion Potion on another and it swapped to the male sprite in both cases.

    Double zoo:
  13. Eikre

    Eikre Member

    I think I understand why I was having trouble with the modloader. My username on the computer I've been testing on is "Völuspá" and the log indicates that the full path to the mods\ directory is "No Good!" It makes sense to me that non-ASCII characters might cause problems, but since those same characters are actually in people's names, uh, maybe this is a thing which should be worked out.

    Anyway the rest of you should try testing it out. I made this example mod which I'm uploading with this post.

    Navigate to C:\Users\Username\Documents\Gaslamp Games\Dungeons of Dredmor (or C:\Documents and Settings\Username\My Documents\Gaslamp Games\Dungeons of Dredmor). I don't know where the folder is located in *nix but it should be the same place your save-games get stored, NOT the directory in which the game is installed. Add a folder called "mods" and then drop the zip-file into that. Then, when you launch the game, hit the button that says "mods" and there should be an entry, which you can enable by hitting the checkbox in the rightmost column. If you want to check and see if it works in-game, make a character with alchemy and check the very last entry of the recipe book; there should be a new entry right after the one to make brimstone out of diggle eggs.

    See if you can get the modloader to break. I don't think you'll be able to; As long as you don't have a bad directory, it seems to work great!

    Attached Files:

  14. Copycat Zero

    Copycat Zero Member

    Well, the basic form on the mod works: the item in question is appearing in the recipe list. Now to (try to) find the ingredients and see if it will let me make the item.

    Oddly enough, there IS a folder called "mods" in the main game folder. I'm assuming you tried to put the mod there and it didn't work? (I suppose I could test it for myself the next time I start the game, but I'm too lazy to quit and restart right this moment.)

    It's probably worth noting that the name of the mod exceeds the boundaries of box for it on the mod list. They might want to look into that (either limiting the number of characters in the mod name or else setting it up so that the name wraps to the next line).
  15. Eikre

    Eikre Member

    No, we've hashed it out with Nick, the folder in the installation directory does nothing, it's misleading and he's getting rid of it. The mod itself works fine, and even if there's a problem with my code it's okay, it's just an example to take the game itself to task.

    Speaking of formatting, the appearance in very low resolutions could use a little bit of looking at:

  16. Copycat Zero

    Copycat Zero Member

    It would be nice if they included the ability for the game to remember which mods were enabled from session to session, rather than having to go in every time and enable them (or even having to go in through the mod menu rather than loading from the basic launcher). In particular, I'm curious of what effect loading a game that doesn't have a particular mod enabled would have if that save had an item added by that mod in its inventory. I wanted to test it with that mod, but I was never able to find the tin (quick mode = fewer chances to find gear and items) before I died (less gear and items = squishier character).

    On a slightly more bug-related note, the game doesn't think you have items that you're storing in your belt. That is, if you put your crafting tools in your belt slots, the keyboard shortcuts for them no longer work because the game thinks you don't have them anymore.

    The autolooting behavior that is apparently a bug has created another bug: If you transmute a gem, it will loot to you with a message of "You put [gem] in your bag"; if it transmutes to a gem of the same type, it vanishes but you still get the same message (at least, if you don't already have a stack of that gem in your inventory). I can also confirm the "if you try to autoloot but your inventory is full, you lose the item".
  17. Eikre

    Eikre Member

    Okay yeah good point use this one instead, it lets you make them at level 0 alchemy and out of nothing but softballs. Start with Alchemy and Throwing and you should be able to mill a few out immediately.

    Attached Files:

  18. Copycat Zero

    Copycat Zero Member

    And the answer is, dun-dun-dun-DUN, the game crashes if you try to load a game that is using a mod that adds items to your game without having said mod enabled. And it didn't even generate a crash log when it did.

    Item works perfectly, by the way, and is rather cool. I wonder if there wouldn't be a way to set it up to randomly generate any of the available pets, rather than just the one?

    By the way, what's the variable "maxstack" supposed to do? I see it on several of the bolts and throwing weapons in the itemDB, including your new item, but I've never seen anything that would indicate that it does something?
  19. Eikre

    Eikre Member

    I looked for randomizing elements and could not find anything like them in the spellsDB, so there wouldn't appear to be a way to randomly summon different monsters with one spell, no. But, you don't have to be limited to just the available pets. You can make a new spell effect to summon something else, and you can author new monsters if you don't like the default choices.

    maxstack determines how many items can be in the stack when you find a pile of them on the ground, in a vending machine slot, or in a chest. Maxstack 1 should make it impossible for you to ever get more than one in any particular spawn instance.

    Bug I just found: When you right-click on a Belt to equip it, instead of unequiping the one you were already wearing and adding it to your inventory, the old belt will just vanish and leave its stats on your character permanently. It's like how taking both Astrology and Archeology used to permanently give you the stats for a Fedora, since the Astrologer's hat overwrote it.

    I can't duplicate the bug with pants or gloves, the belt-slot seems to be the only slot affected.
  20. Essence

    Essence Will Mod for Digglebucks

    When you try to load any new skills, this happens.


    1) The original skills post up twice, but are only selectable down to the circle.
    2) The new skills work oddly: The first one appears at the end of the SECOND iteration of original skills (but too low on the screen to be clickable.) Then the next two appear over the "Last Picks" and "Random" buttons, but are clickable. Then any beyond those two appear after the first one, at the end of the second iteration of original skills (and still unclickable.)

    The end result is that only the second two skills you add to your mod can actually be chosen; and if you have those skills in your mod, you don't get your Last Picks or Random buttons. It seems to me like the problem is probably a result of the way the mod handler loads new skills (i.e. for some reason it loads all of the old skills over again first.)

    I'm sure there's plenty more to come from me. :)